0
Найти на сайте: параметры поиска

 

 

Вылетает Okular

Okular закрывается при попытке открыть PDF из него.
  
Сообщений: 386
Как я уже сказал в описании, Okular закрывается при попытке открыть PDF из него.
А при открытии "с помощью" или через "ассоциацию", Okular ругается: "Невозможно найти модуль для обработки документа.".

Какой еще модуль и какие еще вообще приблуды ему нужны ??
Сообщений: 0
x230:
Какой еще модуль и какие еще вообще приблуды ему нужны ??
запустить okular через терминал, посмотреть выхлоп при ошибке
Сообщений: 386
Chocobo:
запустить okular через терминал, посмотреть выхлоп при ошибке

Вот, выхлоп:
Could not find 'klauncher' executable.
kdeinit4: Communication error with launcher. Exiting!
okular(2678): No ksycoca4 database available!

okular(2678)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType "okular/Generator" not found
okular(2678)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(2678)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
okular(2678)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
Could not find 'klauncher' executable.
kdeinit4: Communication error with launcher. Exiting!
okular(2678)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
Could not find 'klauncher' executable.
kdeinit4: Communication error with launcher. Exiting!
okular(2678): No ksycoca4 database available!

okular(2678)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType "KParts/ReadOnlyPart" not found
okular(2678): No ksycoca4 database available!

okular(2678)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType "KParts/ReadOnlyPart" not found
Could not find 'klauncher' executable.
kdeinit4: Communication error with launcher. Exiting!
KCrash: Application 'okular' crashing...
KCrash: Attempting to start from kdeinit
KCrash: Connect sock_file=/home/x230/.kde/socket-321s/kdeinit4__0
Warning: connect() failed: : В соединении отказано
KCrash: Attempting to start directly
KCrash failed to exec(), errno = 2
Unable to start Dr. Konqi
Not forwarding the crash to Apport.
Редактировалось: 4 раз (Последний: 15 ноября 2015 в 18:18)
Сообщений: 0
x230, у вас KDE?
Сообщений: 386
sizonov_stas:

x230, у вас KDE?

Нет. У меня стоит MATE 1.10.2 (Mint 17.2 (64)).
Сообщений: 0
скорее всего, окуляр не подтянул зависимости кдешные
Сообщений: 0
http://imgur.com/QZs8U9J
Сообщений: 386
sizonov_stas:
...

Рою дальше ...
Только вот рыть придется методом тыка или перебором всех пакетов KDE sad
Сообщений: 0
Код BASH:
  1. $ apt show okular
  2. Пакет: okular
  3. Состояние: не установлен
  4. Версия: 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1
  5. Приоритет: необязательный
  6. Раздел: graphics
  7. Сопровождающий: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
  8. Архитектура: i386
  9. Размер в распакованном виде: 3.824 k
  10. Зависимости: libokularcore5 (= 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1), libc6 (>=
  11. 2.4), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1),
  12. libjpeg8 (>= 8c), libkactivities6 (>= 4:4.9.80),
  13. libkdecore5, libkdeui5, libkexiv2-11, libkio5,
  14. libkparts4, libkprintutils4, libkpty4, libphonon4 (>=
  15. 4:4.6.0really4.3.80), libpoppler-qt4-4 (>= 0.22.1),
  16. libqca2 (>= 2.0.2), libqimageblitz4 (>= 1:0.0.4),
  17. libqmobipocket1, libqt4-dbus (>= 4:4.6.1),
  18. libqt4-declarative (>= 4:4.7.0~rc1), libqt4-svg (>=
  19. 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>=
  20. 4:4.8.0), libqtgui4 (>= 4:4.8.0), libsolid4, libspectre1
  21. (>= 0.2.3), libstdc++6 (>= 4.1.1), phonon, zlib1g (>=
  22. 1:1.2.3.4)
  23. Предлагает: ghostscript, jovie, okular-extra-backends (=
  24. 4:4.14.2-0ubuntu1~ubuntu14.04~ppa1), poppler-data,
  25. texlive-binaries, unrar
  26. Повреждает: kdegraphics-mobipocket (< 4:4.12)
  27. Предоставляет: pdf-viewer, postscript-viewer
  28. Описание: Универсальная программа для просмотра документов
  29. Okular — универсальная программа для просмотра документов, поддерживающая
  30. аннотации, формы и вложенные файлы.
  31.  
  32. Этот пакет содержит приложение для просмотра документов и дополнительные модули
  33. для просмотра таких типов документов, как:
  34. * PostScript (PS)
  35. * Portable Document Format (PDF)
  36. * OpenDocument Text (ODT)
  37. * Независимый от устройств формат файлов TeX (DVI)
  38. * XML Paper Specification (XPS)
  39. * факсы G3
  40. * различные форматы электронных книг: ComicBook, FictionBook и Plucker
  41.  
  42. Этот пакет является частью графического модуля KDE.
  43. Сайт: http://www.kde.org/
Сообщений: 386
x230:
...

Заработало только после этих пакетов:

kdelibs5-plugins (4:4.14.2-0ubuntu1~ubuntu14.04~ppa1)
kdoctools (4:4.14.2-0ubuntu1~ubuntu14.04~ppa1)
libkde3support4 (4:4.14.2-0ubuntu1~ubuntu14.04~ppa1)
libkhtml5 (4:4.14.2-0ubuntu1~ubuntu14.04~ppa1)
libkntlm4 (4:4.14.2-0ubuntu1~ubuntu14.04~ppa1)
libpolkit-qt-1-1 (0.103.0-1ubuntu1)
libqt4-qt3support (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1)
Редактировалось: 2 раз (Последний: 15 ноября 2015 в 18:57)
Сообщений: 0
x230, а чем вас evince не устраивает, или что там в MATE?
Сообщений: 386
sizonov_stas:
x230, а чем вас evince не устраивает, или что там в MATE?

А и им пользуюсь... Просто гигтеговские просмотровщики повторно стартуют с начала последней страницы (на которой закончил читать), а Okular именно с того места, где закончил. Плюс сглаживание шрифтов, плюс еще фишечки по-мелочи...

Я долгое время вообще пользовался SumatraPDF (через Wine), но он долго запускается. Также долго пользовался fb2-читалкой Alreader (также через Wine), - сейчас поменял на CoolReader-3 (привык уже к двухстраничному виду).

Также долго пользовался Kate (до переустановки оси) но потом меня надодумили попробовать Medit - почти то же (в плане кодировок), что и Kate.

Так что я не зацикливаюсь на одном. Всяко пробую.
Редактировалось: 3 раз (Последний: 15 ноября 2015 в 19:07)
Сообщений: 0
x230:

sizonov_stas:
x230, а чем вас evince не устраивает, или что там в MATE?

А и им пользуюсь... Просто гигтеговские просмотровщики повторно стартуют с начала последней страницы (на которой закончил читать), а Okular именно с того места, где закончил. Плюс сглаживание шрифтов, плюс еще фишечки по-мелочи...

Я долгое время вообще пользовался SumatraPDF (через Wine), но он долго запускается. Также долго пользовался fb2-читалкой Alreader (также через Wine), - сейчас поменял на CoolReader-3 (привык уже к двухстраничному виду).

Также долго пользовался Kate (до переустановки оси) но потом меня надодумили попробовать Medit - почти то же (в плане кодировок), что и Kate.

Так что я не зацикливаюсь на одном. Всяко пробую.
А
qpdfview пробовал? вкладочный русский интерфейс, открывает пдф и дежавю файлы, мне он больше по-душе пришелся.
Сообщений: 386
sulako:
qpdfview пробовал?

Пробую уже ... спсб!
Сообщений: 386
sulako:

Не запоминает положение страницы последнего открытого документы (файла), - открывает эту страницу сначала. Как и большинство pdf-вьюеров.

А в остальном мне тоже - по душе.
========

Так что пока сижу на Okular'е
Редактировалось: 2 раз (Последний: 16 ноября 2015 в 18:07)
В начало страницы 
|
Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.