0
Найти на сайте: параметры поиска

 

Compiz-Mate1.4+Emerald

Сборка для систем на базе Ubuntu Presice i386
  
Сообщений: 0
Приветствую Всех!Я уже как-то создавал подобную тему,но тогда речь шла о скомпилированных пакетах из исходников что в этой теме http://forums.mate-desktop.org/viewtopic.php?f=16&t=869 Но тогда мне не удалось собрать два недостающих пакета,а разбираться не было времени.На сей раз,я воспользовался наработками проекта"pointlinux",заимствовал уже собранные пакеты для Debian отсюда http://packages.pointlinux.org/ последовательно распаковав пакеты и отредактировав зависимости под Presice,собрал обратно.В архиве все необходимые пакеты для нормальной работы Compiz http://yadi.sk/d/0Chs3oP83nSBb Порядок установки точно такой же как я описывал в прошлой,удаленной теме,но для новичков,рассказываю ещё-раз.Сначала удаляем все пакеты относящиеся к Compiz,через менеджер пакетов или терминал,заходим в редактор конфигурации,меняем оконный менеджер с Compiz на Marco,командуем marco --replace ,выполняем перезагрузку.Устанавливаем пакеты в том порядке как написано в текстовом файле(есть в архиве).После установки всех пакетов,заходим в редактор конфигурации,меняем оконный менеджер с Marco на Compiz,командуем compiz --replace Если команда"Выполнить"не вызывается через комбинацию клавиш"Alt+F2",назначьте выполнение этой команды на любую из панелей(временно).Затем снова выполняем перезагрузку,кому нужно устанавливаем Ubuntu-Tweak,ну и собственно,на этом пока всё.P.S.Эти пакеты адаптированы только под окружение Mate 1.4,под 1.6 не работает декоратор,как только исправят для Debian,я выложу обновленную сборку.Ставим,проверяем,пишем у кого как работает.
Редактировалось: 4 раз (Последний: 4 апреля 2013 в 22:05)
Сообщений: 0
Спасибо! Всё отлично работает. Единственное, после двух недель работы, начал лагать драйвер NVIDIA-173.14.37. Переустановил на NVIDIA-313.09 всё ок.
Сообщений: 0
Вчера на Виртуалбоксе ради интереса попробовал накатить это на Минт 13 мате. Пакет compiz-mate при установке пишет ошибку зависимости libatk1.0 (>= 2.6). Стоит версия 2.4. Ладно, думаю, написано же русским по белому, что сборка для систем на основе убунту, а не для минт. Смотрю на основной машине ubuntu 12.04, а у меня этот пакет той же версии(( В чём может быть причина?
И второй вопрос: на днях на ланчпаде стал доступен репозиторий с эмеральдом более новой версии. Стоит ли пробовать устанавливать эмеральд оттуда или пакет в сборке "заточен" под компиз, который там же присутствует?
Спасибо.
Редактировалось: 2 раз (Последний: 26 мая 2013 в 15:53)
Сообщений: 0
romek:

Вчера на Виртуалбоксе ради интереса попробовал накатить это на Минт 13 мате. Пакет compiz-mate при установке пишет ошибку зависимости libatk1.0 (>= 2.6). Стоит версия 2.4. Ладно, думаю, написано же русским по белому, что сборка для систем на основе убунту, а не для минт. Смотрю на основной машине ubuntu 12.04, а у меня этот пакет той же версии(( В чём может быть причина?
И второй вопрос: на днях на ланчпаде стал доступен репозиторий с эмеральдом более новой версии. Стоит ли пробовать устанавливать эмеральд оттуда или пакет в сборке "заточен" под компиз, который там же присутствует?
Спасибо.
Причина в том,что вполне может быть что в Mint 13,libatk1.0 версии 2.4,а не 2.6 как в Ubuntu 12.04,но пакетная база у них одна.Это просто нужно убрать версию либы в зависимостях пакета compiz-mate,чтобы не создавался конфликт.Перепаковал,адрес ссылки тот же,скачайте обновленный пакет compiz-mate из архива.Теперь должно на Mint 13 пойти без проблем.По второму вопросу:не стоит,если собираетесь использовать мою сборку Compiz,т.к. новая версия Emerald,скорее всего не установится по зависимостям.
Редактировалось: 5 раз (Последний: 27 мая 2013 в 01:50)
Сообщений: 0
Большое спасибо. На основной машине стоит 12.04, но там тоже версия libatk1.0-0 2.4 sad

Этот злосчастный пакет удалить не смог: "тянет" за собой почти все установленные приложения, вплоть до flashplugin. Нашёл версию 2.6 в пакетах для Ubuntu 12.10, но устанавливаться поверх тот категорически отказывался и через gdebi, и через gksu в терминале.
Так как нашёл репозиторий с Mate 1.4, попробую ещё поэкспериментировать на виртуалке (и с Linux Mint - тоже ради интереса). По результатам отпишусь. Цель - переустановить основную систему: 1.6 с компизом не дружит, а более работоспособной сборки, в т.ч с эмеральдом найти не удалось.
Ещё раз спасибо.

P.S. Я прошу прощения за невнимательность; 2 пакета - libemeraldengine и emerald имеют ту же зависимость от libatk1.0-0 (>= 2.6). ((( Попробовал с Эмеральдом из репозитория - не работает (нет рамок).
Редактировалось: 4 раз (Последний: 27 мая 2013 в 15:35)
Сообщений: 0
romek:

Большое спасибо. На основной машине стоит 12.04, но там тоже версия libatk1.0-0 2.4 sad

Этот злосчастный пакет удалить не смог: "тянет" за собой почти все установленные приложения, вплоть до flashplugin. Нашёл версию 2.6 в пакетах для Ubuntu 12.10, но устанавливаться поверх тот категорически отказывался и через gdebi, и через gksu в терминале.
Так как нашёл репозиторий с Mate 1.4, попробую ещё поэкспериментировать на виртуалке (и с Linux Mint - тоже ради интереса). По результатам отпишусь. Цель - переустановить основную систему: 1.6 с компизом не дружит, а более работоспособной сборки, в т.ч с эмеральдом найти не удалось.
Ещё раз спасибо.

P.S. Я прошу прощения за невнимательность; 2 пакета - libemeraldengine и emerald имеют ту же зависимость от libatk1.0-0 (>= 2.6). ((( Попробовал с Эмеральдом из репозитория - не работает (нет рамок).

Переделал пакеты libemeraldengine и emerald,убрав в зависимости libatk1.0-0 номер версии.Скачайте,попробуйте.
Сообщений: 0
Спасибо, попробовал.
В Virtualbox результатов никаких: изображение дёргается, рамки окон периодически "отваливаются", помогает рестарт компиза через fusion icon sad По видимому, проблема именно в самой Virtualbox (( То ли видеопамяти 128 из максимально отведенных мало, то ли ещё чего... Linuxmint 13 Mate на первых четырёх пакетах выдал неразрешённую зависимость с чем-то, больше я не экспериментировал.
С аналогичной последовательностью установил систему на флешку, накатил на неё Mate 1.4, установил всё по инструкции - всё замечательно: ничего не дёргается и ничего не отваливается; такая же картина при использовании проприетарного драйвера dance
Единственное (может кому полезно будет), - после установки ядра 3.9.4 всё работать перестало. В общем, поле для экспериментов остаётся, буду переустанавливаться на HDD.
Ещё раз спасибо за сборку пакетов и за внимание, проявленное к моим вопросам.
Сообщений: 0
Хороший ты человек! Все просто песенка! масштабирование работает плавно, окошки над кубом парят, все работает уверенно и мягко! Обнял прям!
Только вот есть ли грамотный способ это все одной командой замакросить-затерминалить? а то последовательно 15 раз пароль вводить по инструкции - героизм. и это, надо нафиг сразу обновления откючать, чтоб такой труд не пропал. Линуксу это можно, здесь точно лучшее- враг хорошего.
Редактировалось: 1 раз (Последний: 21 июня 2013 в 01:59)
Сообщений: 0
СвежийВетер:

Хороший ты человек! Все просто песенка! масштабирование работает плавно, окошки над кубом парят, все работает уверенно и мягко! Обнял прям!
Только вот есть ли грамотный способ это все одной командой замакросить-затерминалить? а то последовательно 15 раз пароль вводить по инструкции - героизм. и это, надо нафиг сразу обновления откючать, чтоб такой труд не пропал. Линуксу это можно, здесь точно лучшее- враг хорошего.
Как вариант,скопировать все пакеты в корень домашней папки и через терминал sudo dpkg –i ./*.deb Я не проверял это решение,но возможно и получится...Кто проверит,отпишитесь.
Редактировалось: 4 раз (Последний: 25 июня 2013 в 02:25)
Сообщений: 0
не, с корневой то жесть, можно просто в папку, только на всякий случай без верхних уровней с кириллицей, оттуда открыть в терминале, и там уже командовать. Мне вот интересно - важен порядок исполнения команд, если тупо задать исполнение по шаблону, оно будет выполняться по алфавиту? как задать по требуемому порядку? Последовательностью через запятые, кто знает? я бы погонял, но неначем сейчас. и интересен синтаксис такой группровой установки - sudo dpkg –i ./*.deb, пакет2.deb, и т.д? что-то типа того?
Редактировалось: 2 раз (Последний: 30 июня 2013 в 22:32)
Сообщений: 0
Приветствую всех пользователей Mate DM smile Ну что могу сказать,нас можно поздравить,сегодня собрал пакеты Compiz под Mate1.6 http://yadi.sk/d/QFzI8FTA7w2TO v ,не выдержала душа поэта joke Метод установки прежний,инструкция в архиве.Версии пакетов оставил те же что и для Mate1.4 ,с тем,чтобы у кого уже установлены пакеты для Mate1.4,смогли без проблем переустановить пакеты music Всё проверено,работает декоратор с Compiz,сочетания клавиш Alt+F1,Alt+F2,но конечно не без ложки дёгтя...(не волнуйтесь).В режиме Compiz,рамки окон не подхватываются из выбранных тем sad На данный момент, этот баг в Mate1.6 пока не устранен ни в одном из существующих дистрибутивов.В любом случае это поправят в самое ближайшее время.Мной было найдено следующее решение,а именно,обращаться к Compiz-Decorator минуя Compiz-Fusion-Icon laugh И чтобы каждый раз не вводить соответствующую команду,можно через ПМК -> Добавить на панель -> Пользовательская кнопка запуска -> Имя: (я назвал Compiz-Mate-GTK) -> Команда: compiz-mate-gtk -> Примечание: (не обязательно) ,также можно назначить любую иконку,та что у меня(есть в архиве с пакетами).Теперь после смены любой темы в режиме Compiz,достаточно нажать на созданную кнопку и рамки окон будут подхватываться из текущей темы.После перезагрузки,оформление рамок слетает,соответственно нужно нажать заветную кнопочку.Вот собственно и всё.Пишите у кого как получилось. glasses
Редактировалось: 3 раз (Последний: 15 августа 2013 в 10:23)
Сообщений: 0
Пробовал по шаблону, сразу ругается на зависимости, так как надо последовательно, через запятые не хочет, или я с синтаксисом туплю. Но если тупо повторить 6-8 раз шаблонную установку, ставицца crazy
Сообщений: 0
СвежийВетер:

Пробовал по шаблону, сразу ругается на зависимости, так как надо последовательно, через запятые не хочет, или я с синтаксисом туплю. Но если тупо повторить 6-8 раз шаблонную установку, ставицца crazy
Нужно по внимательнее посмотреть по зависимостям в пакетах,я имею ввиду себя.Только что обнаружил в compiz-core зависимость пакета fglrx,это хорошо тому у кого видео от ATI/AMD как у меня.а если карточка Nvidia или Intel,уже косяки начнутся.Этот пакет я перепаковал,обновил в архиве.Посмотрю дальше все пакеты.Так-что если будут проблемы при установке,просьба сразу сообщать!!!
Сообщений: 0
mate 1.2, 1.4, 1.6 - всегда делал так: http://www.mintlinux.ru/blogs/izmyshlizmy/linux-mint-13-mate-compiz-emerald.html и ни разу не возникало проблем...
Сообщений: 0
В 14-м по такой схеме окна над кубом парят? При установке из стандартных репов у меня ни на одной машине не работало - с активными парящих окнами при клике средней кнопкой куб исчезает, а парящие окна рисуют трассеры. С любым видео. В Авторской сборке компиза проблем нет совсем.
В начало страницы 
|
Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.
test