0
Найти на сайте: параметры поиска

 

 

Проблема с 2 gis

Недоступны строки "Что", "Где", "От", "До"
  
Сообщений: 0
ОС: linux mint 18 cinnamon
Wine: 1.8
После установки любого варианта 2 gis (т.е. и MSI, и вариант для wine из официального сайта ) не доступны в поиске строки "Что", "Где", "От", "До" (эти слова там просто выделены жирным прям на строчках и ввести ничего не получается).
Но вот если установить 2 gis через Synaptic
Код PHP:
  1. deb http://packages.redsolution.ru/2gis hardy non-free
то там все нормально, но база там очень старая. Если пытаться сменить базу в /usr/lib/2 gis, то карта не загружается, просто выводится окно обновления 2 gis (при этом стоит галка, что типа Казанская база обновлена). Дальше никак не пройти. Как правильно установить?
Пробовал ставить Wine 1.9.12 - не помогает, ну и куда-то пропадают из меню "Открыть диск С", "Настройки Wine", что тоже неудобно.
Сообщений: 0
Bill Williamson, Hardy - это жестоко hoho
Попробуйте отсюда взять http://deb.2gis.ru/ для 17-й версии (trusty)

Впрочем судя по отму что творится на их сайте - нативную версию они забросили напрочь.
Сообщений: 0
Chocobo:

Попробуйте отсюда взять http://deb.2gis.ru/ для 17-й версии (trusty)...
Выводит такую ошибку:
sudo apt-get install 2gis
[sudo] пароль для ___:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
2gis : Зависит: libc6 (< 2.20) но 2.23-0ubuntu3 будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.
Сообщений: 0
Значит на Сару его похоже не втащим (у меня та же ошибка с нативной). look
Вайн не юзаю сейчас. Мож кто другой проверит на 18-й версии...

А в общем, думаю вопрос о поддержке Xenial- к самим разрабам сего продукта

http://help.2gis.ru/feedback/
Сообщений: 0
Поколдовал с пакетом, удалось подружить его с нашей новой пассией. hoho

Здесь пересобранный пакет, который у меня успешно установился на 18.

А дальше надо прячем от него все притащенные им библиотеки:

Код BASH:
  1. mv /usr/lib/2GIS/v4/lib/ /usr/lib/2GIS/v4/lib2/
Затем запускается норм:



Вроде как что-то работает ,проверяй)
Редактировалось: 1 раз (Последний: 23 июня 2016 в 01:38)
Сообщений: 0
Chocobo, а можешь поколдовать для 32-битной версией,)
у меня на 17-17.3 спокойно встает.
Сообщений: 0
demons-angels, нет сейчас 32-х битной машинки чтоб проверить. Будет времечко - разверну где-нибудь.
Пока не понял есть ли смысл - базы годовалой давности, и обновляться сами будут вряд ли, ибо нативная версия заброшена.
возможно ли организовать обновление в ней ручками - пока не уверен, совместимость могли давно нарушить.

Мне кажется эти сервисы удобней юзать на смартфоне/планшете или в вебе, чем держать десктопное приложение.
Сообщений: 0
Chocobo:

Мне кажется эти сервисы удобней юзать на смартфоне/планшете или в вебе, чем держать десктопное приложение.
По работе ежедневно пользуюсь гисом - гораздо удобнее в вебе - все всегда обновлено. С ужасом вспоминаю привычку виндовскую держать гис офлайновую на компутере.
Редактировалось: 1 раз (Последний: 23 июня 2016 в 17:45)
Сообщений: 0
Genghaev:

Chocobo:

Мне кажется эти сервисы удобней юзать на смартфоне/планшете или в вебе, чем держать десктопное приложение.
По работе ежедневно пользуюсь гисом - гораздо удобнее в вебе - все всегда обновлено. С ужасом вспоминаю привычку виндовскую держать гис офлайновую на компутере.
Часто бывает, что Интернета нет. И видимо Вы не пользуетесь модулем слои, а мне он нужен.
Сообщений: 873
Bill williamson:
ОС: linux mint 18 cinnamon
Wine: 1.8
После установки любого варианта 2 gis (т.е. и MSI, и вариант для wine из официального сайта ) не доступны в поиске строки "Что", "Где", "От", "До" (эти слова там просто выделены жирным прям на строчках и ввести ничего не получается).

ОС: linux mint 18 cinnamon
Wine: 1.6.2 (тот что по умолчанию из реп через синаптик пс минимальной установкой , всего то пара пакетов установлена)
2ГИС c офсайта, версия для линукса в zip-архивах скачанная и распакованная на раздел файлопомойки и оттуда же и запущенная

и всё нормально работает
Редактировалось: 1 раз (Последний: 8 августа 2016 в 11:23)
"Не ты выбираешь Linux, а Linux выбирает тебя"
(с)Себастьян Перейра, торговец чёрным деревом
Сообщений: 0
Не знаю что помогло, но все заработало.
ОС: Linux Mint 18 Cinnamon x32
Wine: 1.8.4 (ставил по официальной инструкции ветку devel)
Оболочка 2GIS: 2GISShell-3.16.3.0.msi
База: 2GISData_Kazan-93.orig.zip Казань Август
Ну и поставил стандартные Windows шрифты, как это советуют на сайте 2ГИС.
Возник еще один вопрос. Когда ставится какая-либо программа через wine, на рабочем столе создается ярлык на запуск. Так вот, откуда этот ярлык берет значок?
В начало страницы 
|
Перейти на форум:
Быстрый ответ
Чтобы писать на форуме, зарегистрируйтесь или авторизуйтесь.