0
Найти на сайте: параметры поиска

 

 

[РЕШЕНО] 32 битный *.run и 64 битный Mint

Проблема с запуском *.run файла на Linux Mint 17.3 Mate
  
Сообщений: 0
Всем привет. Начну с того, что я гуглил этот вопрос 2 дня и на наших и на забугорных форумах. И либо лыжи не едут, либо я, как говорится. Поскольку Linux пользуюсь относительно недавно, могу подтупливать, прошу понять и простить.

К проблеме:

На пк установленна Linux Mint 17.3 с окружением MAte
вот вывод cat /proc/verion: Linux version 3.19.0-32-generic (buildd@lgw01-43) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1) ) #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015

Необходимо установить торговое ПО из файла *.run, про него знаем что оно 32 битное и готовилось под Ubuntu 12.04.02 LTS 32bit
FrontolxPOS-linux-install.run

Проблема следующая - не запускается этот самый *.run. Файл сделал исполняемым - при двойном щелчке ничего не происходит.
вывод из терминала:
sh FrontolxPOS-1.7.0-linux-setup.run
FrontolxPOS-1.7.0-linux-setup.run: 1: FrontolxPOS-1.7.0-linux-setup.run: Syntax error: "(" unexpected

./FrontolxPOS-1.7.0-linux-setup.run
Ошибка сегментирования

В чем может быть проблема, и как её решить? Заранее благодарю за помощь
Сообщений: 0
попробуйте так:

Сообщений: 0
Попробовал из под суперпользователя и ранее, ну вот и сейчас
Wolf Загрузки # ./FrontolxPOS-1.7.0-linux-setup.run
Ошибка сегментирования

Может библиотек каких не хватает? Вот только каких...
Редактировалось: 1 раз (Последний: 19 апреля 2016 в 12:42)
Сообщений: 0
DrWOLF, на сайте довольно скудная инфа:
Совместимость с ОС
Windows XP / 7
Ubuntu 12.04
Совместимость с Windows 8, 8.1 и 10 и другими дистрибутивами Linux не проверялась

Т.е. на 13-м минте может и взлетит.
А лучше все-таки этот вопрос им адресовать, наверное
Сообщений: 0
К сожалению ответ сапорта мне известен: "Проверялось на Ubuntu 12.04, совместимость с другими версиями не проверяли, можете попробровать прикрутить сами, но работу мы не гарантируем". Как вы и написали. Сам в такой же конторе работаю... Поэтому вопрос, а можно ли прикрутить остается открытым.

И я так понимаю, что имеется в виду именно работоспособность приложения, а не сам факт установки. Т.е. по логике скрипт установки должен по крайней мере запустится. Или я не прав, и из-за разных версий он как раз таки может не запускаться?
Сообщений: 1087
DrWOLF, может, все дело в том, что 32 битный *.run и 64 битный Mint?
linuxmint.com.ua
Сообщений: 0
sizonov_stas:

DrWOLF, может, все дело в том, что 32 битный *.run и 64 битный Mint?

А я думал что

wolf@Wolf ~ $ arch
x86_64

значит что можно использовать и ту и другую архитектуры, соответвено при присутствии надлежащих библиотек. Это не правда?
Сообщений: 806
DrWOLF, deb пакет же есть - http://fs.atol.ru/SitePages/%D0%A6%D0%B5%D0%BD%D1%82%D1%80%20%D0%B7%D0%B0%D0%B3%D1%80%D1%83%D0%B7%D0%BA%D0%B8.aspx первая ссылка.
Сообщений: 0
Unborn:

DrWOLF, deb пакет же есть - http://fs.atol.ru/SitePages/%D0%A6%D0%B5%D0%BD%D1%82%D1%80%20%D0%B7%D0%B0%D0%B3%D1%80%D1%83%D0%B7%D0%BA%D0%B8.aspx первая ссылка.

Он под arm, для моноблока nova.
Сообщений: 1087
DrWOLF:

sizonov_stas:

DrWOLF, может, все дело в том, что 32 битный *.run и 64 битный Mint?

А я думал что

wolf@Wolf ~ $ arch
x86_64

значит что можно использовать и ту и другую архитектуры, соответвено при присутствии надлежащих библиотек. Это не правда?

у меня 32, лично не проверял
linuxmint.com.ua
Сообщений: 0
DrWOLF, попробуй с
Код PHP:
  1. sudo dpkg --add-architecture i386
и еще - в /tmp он пишет логфайл - /tmp/bitrock_installer_<PID>.log

может там что-то остается
Сообщений: 0
Chocobo:

DrWOLF, попробуй с
Код PHP:
  1. sudo dpkg --add-architecture i386
и еще - в /tmp он пишет логфайл - /tmp/bitrock_installer_.log

может там что-то остается

логи пустые и весят 0B
Сообщений: 0
засада прям :)
Тогда вернемся к
DrWOLF:
Может библиотек каких не хватает? Вот только каких...

вот листинг того, что из файлов он держит у меня при запуске => http://pastebin.com/pJbPGC8p
Сообщений: 0
Это конечно круто, но у меня пока не хватает опыта, что бы выяснить из данного листинга какие библиотеки он подтягивает (хотя общий смысл я понял, но гугл мне в этом не то, чтобы сильно помог). Объясните куда смотреть пожалуйста. Я завтра попробую сверить со своими.
Сообщений: 0
DrWOLF, там в правой колонке пути к файлам, в основном, думаю, интересуют те что /usr/lib/

и еще один момент,
Спойлер
если предположить,что может сегфолтится на gui, можно попробовать такой вариант:


ну и можно добавить следующие пакеты, на всякий случай, т.к. инфы маловато у нас:
Код PHP:
  1. sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5 dkms linux-headers-$(uname -r)
Редактировалось: 2 раз (Последний: 19 апреля 2016 в 16:26)
В начало страницы 
|
Перейти на форум: