0
Найти на сайте: параметры поиска

 

 

[РЕШЕНО] Не могу запустить VirtualBox в ядре 4.5

При переходе на новое ядро не запускается VirtualBox
  
Сообщений: 30
Установлен у меня Linux Mint Cinnamon 17.3

После перехода на ядро 4.2.5 перестал включаться VirtualBox, выдает ошибку:
Спойлер
Команду sudo /sbin/rcvboxdrv setup делал, на нее выдается вот что:
Спойлер
Далее смотрю логи предложенных файлов
var/lib/dkms/vboxhost/5.0.12/build/make.log :

Спойлер
и другой файл /var/log/vbox-install.log :
Спойлер
Вот только в этих логах ничего понять не могу.
Так же пробовал установить/переустановить модуль DKMS, но выдается что установлено самое новое.
При переходе на ядро 3... (на старое мое ядро) virtualbox включается нормально, но новое ядро работает на моем компе заметно быстрее. Не хотелось бы переходить на старое.
Сообщений: 0
Я таки понимаю, что люди делятся на две категории:
1) Те кто уже понял, что установка "левых ядер" - это геморрой со всякими последствиями
2) И те кому это ещё предстоит понять.

Только оф. Сборки ядер в менеджере обновлений (4.2 на сегодня последнее). Иначе ждите косяков...
Сообщений: 30
hardir:
т.е. лучше перейти на 4.2?
Сообщений: 0
colobok09, чтоб компилировать модули корректно - обычно требуется уcтановить :
Код PHP:
  1. apt-get install build-essential module-assistant
И выполнить
Код PHP:
  1. m-a prepare
А затем уже
Код PHP:
  1. /sbin/rcvboxdrv setup

Также в тексте ошибки указано, что можно сделать проще:
If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

Т.е. попробовать поставить virtualbox-dkms, или, если он уже есть - отконфигурить его

Код PHP:
  1. sudo dpkg-reconfigure virtualbox-dkms
  2. sudo modprobe vboxdrv
Редактировалось: 1 раз (Последний: 22 декабря 2015 в 11:52)
Сообщений: 30
Спасибо большое. Пока решил проблему установив ядро 4.2 из установки приложений. А 4.5 просто удалил. Виртуалбокс работает.
Сообщений: 0
colobok09, даунгрейд - тоже вариант, если установленная версия ядра не критична.
закрывай тогда тему:)
Сообщений: 75
А зачем вы устанавливали ядро 4.2.5 ? ВЫ заметили разницу в работе ядра 4.2 в сравнении с 4.2.5 ?
Сообщений: 30
military:

А зачем вы устанавливали ядро 4.2.5 ? ВЫ заметили разницу в работе ядра 4.2 в сравнении с 4.2.5 ?

У меня было установлено ядро 3.16. И 4.2.5 заметно быстрее работало, на моем компе. Снес я 4.2.5 и поставил 4.2. Полет нормальный. Тему закрываю, хоть вопрос с ядром 4.2.5 и не решился.
Сообщений: 30
тему закрываю
В начало страницы 
|
Перейти на форум: